DNS issue

Resolved
Major outage
Started 4 months ago Lasted about 2 hours

Affected

ledgy.com
app.ledgy.com
Updates
  • Resolved
    Resolved

    We had issues with our DNS that led to the website being inaccessible.

  • Identified
    Identified

    Our automated alerting has identified issues with accessing our systems.